Apple Releases iOS four.3.5 to deal with safety issue With certificate Validation


most effective ten days after releasing iOS 4.3.4, Apple has just pushed out iOS 4.three.5 to deal with a security problem with certificates validation.

iOS four.three.5 tool update

Fixes a security vulnerability with certificate validation.

the new version checks in as build 8L1, and is for the GSM iPhone four, iPhone 3GS, all iPads, and the third- and-fourth-era iPod contact. A separate iOS 4.2.10 (construct 8E600) is available for the CDMA iPhone.

Direct obtain links:
iPhone four GSM
iPhone four CDMA (iOS four.2.10)
iPhone 3GS
iPad 2 Wi-Fi
iPad 2 GSM
iPad 2 CDMA
authentic iPad
iPod contact (fourth-technology)
iPod contact (third-generation)

update: Some customers are reporting receiving blunders when attempting to connect with Apple’s servers for the replace, but with repeated makes an attempt it appears as if users are able to get via.

update 2: Apple has now posted a fortify document describing the safety problem patched in the replace. the issue has been given an identifier of CVE-2011-0228.

impression: An attacker with a privileged network place may just capture or alter information in sessions protected through SSL/TLS

Description: A certificates chain validation issue existed within the managing of X.509 certificates. An attacker with a privileged network place may just capture or modify knowledge in periods safe by means of SSL/TLS. different assaults involving X.509 certificates validation will also be that you can imagine. This problem is addressed through better validation of X.509 certificate chains.

latest Mac and iOS blog stories
Apple signs Deal for 23,000 sq.-Foot Grand critical Terminal store [Update: Rendering]
Making Lion Act more Like Snow Leopard
Nuance Debuts Dragon Dictate for Mac 2.5
iTunes App store Extends to 33 further international locations
Steve Jobs Has No problem Telling You What He Thinks


extra: persevered right here

Leave a Reply