macOS Monterey Users Report Connectivity Issues With USB Hubs

Some Mac users who upgraded to macOS Monterey this week are experiencing problems getting USB hubs and other USB-based devices to work properly with their machines, based on scattered online reports.

There have been several reports on Reddit, Apple’s Developer Forums, and Apple’s Support Communities about the issues. In some cases, users say the the USB 3.0 ports on their hub no longer work since upgrading to Monterey, while HDMI, USB-C, and other hub ports continue to work as expected.

In other user reports surfacing online, the USB hubs fail to work at all. Some of the problems even relate to Apple certified hubs. Reddit user Flyersny81 relates their experience:

My USB-C hub has issues with this update. The HDMI port connected to my second screen is working on the hub but none of the USB3 ports are working at all. I have tried different C ports on the MacMini and different hubs (I have 4). I also replicated this issue on my M1 MacBook Air after updating to Monterey. Here is the hub I am using. These hubs worked perfectly in Big Sur.

Had a call with Apple support and they said to try an Apple certified hub. I used this one I had floating around in my bag and both the HDMI and USB3 ports worked on it. I tried to daisy chain the Amazon hub to the Apple hub but that didn’t work either. Support told me that many people have been complaining about this issue and it will hopefully be fixed in the next patch to be pushed out.In other cases, the USB hubs work except for the power delivery port. For some, it’s the additional connectivity provided by external displays that no longer works, with the power delivery affected in particular. From Apple’s Developer Forums:

PD (Power Delivery) over USB-C also stopped working on my MBP 2018 after updating to Monterey (12.0.1). I use a Philips 346P1CRH. Everything was working flawlessly with Big Sur.

– TommyWi

I have the same issue with my MBP M1 2020 connected with an external Monitor HP S340c. Power Delivery (PD) and Video-Connection not working (but Mouse and Keyboard is still supported/working).

– Tiggar

Same problem as everyone, bought 34″ Philips 346P1CRH/00 and everything worked fine on BigSur… After updating to Monterey, the video and ethernet works, but power supply is cut off. I’m on an M1 Macbook Air. :/

– lenskdav

Essentially, Monterey has broken support for a WIDE number of USB Hubs. Some USB Hubs work but certain ports on the hub do not, some Hubs do not work at all.

For me, USB-C & HDMI work on the hub, but my USB 3.0 port will only power devices and there appears to be no data transfer.

This issue is absolutely a Monterey bug. My devices were working fine prior to upgrading, and I have been able to replicate the issue and narrow it down by testing against a device that does not have Monterey installed.

– macmjs1996Many of the reports are from owners of M1-powered Macs, but not all. Some users have reported similar issues on Intel Macs. Based on user discussions, USB issues were reported in early beta versions of Monterey, suggesting this could be due to a legacy bug that Apple has still not patched.

As such, the problems appear to be evident in all versions of Monterey, including the latest 12.0.1 version. Suffice to say, anyone who has yet to upgrade to Monterey and relies on a USB hub is advised to hold off upgrading until Apple issues a fix.Related Roundup: macOS MontereyRelated Forum: macOS MontereyThis article, “macOS Monterey Users Report Connectivity Issues With USB Hubs” first appeared on MacRumors.comDiscuss this article in our forums

Go to Source
Author: Tim Hardwick