No iOS 5 for iPhone 3GS?


Eldar Murtazin, editor-in-chief of Russian mobile phone blog Mobile-Review today reported in a Tweet (via MacStories) that iOS 5 will not be compatible with the iPhone 3GS, limiting the next-generation operating system to the current iPhone and of course new models yet to come as far as the iPhone is concerned.

Just one comment. Apple iPhone 3Gs wont be upgradable to iOS 5.x. iPhone 4 will.

The information is unverified and it is unclear from where Murtazin obtained the information, but he does have a very solid reputation in the mobile phone rumor community. Murtazin does not, however, frequently report on Apple’s plans.

iOS 4.0 was released last June with compatibility for the iPhone 3G, 3GS, and 4, although some of the iOS 4 features were not available on the older hardware. That fragmentation continued until Apple finally discontinued support for iPhone 3G updates with the release of iOS 4.3 earlier this year, leaving that device at a maximum operating system version of iOS 4.2.1.

Limiting iOS 5 to a minimum of iPhone 4 hardware would be a significant shift toward high-end hardware requirements, particularly considering that Apple still sells the iPhone 3GS. iOS 5 has, however, been reported to be a significant reworking of the company’s mobile operating system, and Apple may simply feel that only the latest hardware (relatively speaking) will offer a satisfactory experience.


More: continued here

Leave a Reply